flutter - VSCode编译遇到"It appears that your application still contains the default signing identifier"

ggid

2018-05-08T06:19:10Z||2018-05-08T06:19:10Z

调试运行出现:

Could not build the precompiled application for the device.
It appears that your application still contains the default signing identifier.
Try replacing 'com.example' with your signing id in Xcode:
  open ios/Runner.xcworkspace

先不要在vscode里折腾,打开ios/Runner.xcworkspace,然后在xcode中修改bundle ID,然后尝试在xcode里编译,如果遇到Signing问题的话,在Signing中选择好正确的team,必要时让xcode自动修复下,总之就是最常见Xcode编译iOS那种证书问题都解决了,确保可以编译成功后,再回到VSCode中编译和调试Dart代码。