2017-10-08T03:57:44Z||2017-10-08T03:57:44Z


TSLint默认的rules里不允许使用require,但是有些时候有一些npm模块没有d.ts定义,于是又不得不使用require来导入模块,所以可以禁用这个rule:

{
    "defaultSeverity": "error",
    "extends": [
        "tslint:recommended"
    ],
    "rules": {
        "no-var-requires": false
    }
}